Absa is experiencing severe issues
Incident Report for Stitch
Resolved
This incident has been resolved.
Posted Jan 14, 2022 - 15:41 SAST
Update
Absa is experiencing an outage and their Web Portal is currently down for all users due to a major outage.
Stitch's platform is still fully operational.
Posted Jan 14, 2022 - 11:42 SAST
Monitoring
Absa is experiencing an outage and their Web Portal is currently down for all users due to a major outage. Stitch's platform is still fully operational.
Posted Jan 14, 2022 - 11:28 SAST
This incident affected: Absa (Login, Payments, Data).